Прошивка устройств на процессоре VIA WM8650

Инструкции для КПК (PPC)

Модератор: чипега

Аватара пользователя
Blaze
Информатик-аналитик
Информатик-аналитик
Сообщения: 8926
Зарегистрирован: 24.05.2007 17:23
Модель телефона: POCO X3 Pro 6/128
Прошивка: crDroid v7.7
Sat-ресивер: Tiviar Mini HD
Откуда: Данков
Контактная информация:

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2341 » Blaze » 30.05.2012 19:19

Joni, через Skype (BETA) пробовали авторизоваться?

poer, модель M009F, как и M010F, M7206, M799ca на базе процессора InfoTMIC x210
Попробуйте прошить планшет с SD-карты (внутренней (внутри планшета на 4 гига) или внешней - без понятия), одной из двух прошивок:
Rossa, где именно вирус?

vik777, планшет прошивали под каким номером (38 или 44) в прошивке Uberoid?

Rossa
Пользователь
Пользователь
Сообщения: 36
Зарегистрирован: 29.11.2011 10:07
Откуда: Букинск

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2342 » Rossa » 30.05.2012 21:30

Blaze, где именно вирус?
при закачке по ссылке антивирус ругается что в архиве вирус... не исключаю что качается криво

Blaze, написал перевод инструкции от srt45 см. здесь,
сделал все как написано здесь, но сделал свои корректировки папку /FirmwareInstall/packages/fs_patch/ взял из прошивки Eken M008s той которой прошили после восстановления загрузчика планшета пользователя qwestik123, в итоге получил все программы из этой прошивки включая нормальный файловый браузер. а pl2303.ko искал 2 дня кой как нашел, поэтому выкладываю здесь.
первый раз планшет грузился не меньше 40 минут, я уж подумывал снести все нахрен, такое ощущение было что он висит, бросил уже его разряжаться, но он таки загрузился...
env_uboot изменил как писал stuz, но мерцание есть... :P

Blaze,чтобы поддержку GPS добавили в Uberoid. Но мое сообщение было проигнорировано.

это жаль, надо настоять на том чтобы сделали поддержку, тем более что в этом нет ничего сложного :wink:

Добавлено спустя 6 минут 33 секунды:
pl2303.ko

poer
Начинающий
Начинающий
Сообщения: 5
Зарегистрирован: 30.05.2012 2:20
Откуда: Казахстан

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2343 » poer » 30.05.2012 22:19

Blaze спасибо за прошивку,но даный девайс как позже выяснилось шьется только через usb,апарат перепрошил работает норм.

DeafenThunder
Начинающий
Начинающий
Сообщения: 5
Зарегистрирован: 28.05.2012 17:52
Откуда: Муром

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2344 » DeafenThunder » 31.05.2012 8:35

uzImage.bin из убиройда, я пробовал тоже все 4, нашел исходники ядра, но пересобрать их под мою flash мне не хватит знаний, может есть где еще сторонние сборки?

Добавлено спустя 17 минут 25 секунд:

Код: Выделить всё

Linux version 2.6.32.9-default (reilienchen@szmce13) (gcc version 4.5.1 (Sourcery G++ Lite 2010.09-50) ) #3 Thu Dec 29 20:07:17 HKT 2011
CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr=00053177
CPU: VIVT data cache, VIVT instruction cache
Machine: WMT
Memory policy: ECC disabled, Data cache writeback
On node 0 totalpages: 54784
free_area_init_node: node 0, pgdat c05cc9ac, node_mem_map c06ad000
  Normal zone: 428 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 54356 pages, LIFO batch:15
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 54356
Kernel command line: log_buf_len=256K mem=214M root=dev/ram0 rw initrd=0x01000000,32768K console=ttyS0,115200n8 loadtime=-4
log_buf_len: 262144
set load time = -4
PID hash table entries: 1024 (order: 0, 4096 bytes)
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 214MB = 214MB total
Memory: 177152KB available (5508K code, 1137K data, 148K init, 0K highmem)
Hierarchical RCU implementation.
NR_IRQS:128
Console: colour dummy device 80x30
console [ttyS0] enabled
Calibrating delay loop... 348.97 BogoMIPS (lpj=1744896)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
NET: Registered protocol family 16
wmt_pci_init
PCI: WonderMidia Technology PCI Bridge
pci 0000:00:01.0: reg 10 io port: [0xd8008100-0xd8008107]
pci 0000:00:01.0: reg 14 io port: [0xd8008144-0xd8008147]
pci 0000:00:01.0: reg 20 io port: [0xd8008180-0xd800818f]
pci 0000:00:02.0: reg 10 io port: [0xd8004000-0xd80040ff]
pci 0000:00:02.0: reg 14 32bit mmio: [0xd8004000-0xd80040ff]
pci 0000:00:04.0: reg 10 32bit mmio: [0xd8007900-0xd80079ff]
pci 0000:00:05.0: reg 20 io port: [0xd8007b00-0xd8007b1f]
pci 0000:00:06.0: reg 20 io port: [0xd8008d00-0xd8008d1f]
PCI: bus0: Fast back to back transfers disabled
[WMT-MB] Preparing VIDEO BUFFER (SIZE 32768 kB) ...
[WMT-MB] MAX MB Area size: Max 4096 Kbs Min 256 Kbs
[WMT-MB] prob /dev/Memory Block major 242, minor 0
bio: create slab <bio-0> at 0
vgaarb: loaded
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
NET: Registered protocol family 2
IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
TCP established hash table entries: 8192 (order: 4, 65536 bytes)
TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 8192 bind 8192)
TCP reno registered
NET: Registered protocol family 1
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
Trying to unpack rootfs image as initramfs...
rootfs image is not initramfs (no cpio magic); looks like an initrd
Freeing initrd memory: 32768K
ashmem: initialized
NTFS driver 2.1.29 [Flags: R/W].
JFFS2 version 2.2. (NAND) © 2001-2006 Red Hat, Inc.
yaffs Dec 15 2011 14:32:40 Installing. 
msgmni has been set to 410
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
un-know id = 0xc84013
un-know id = 0xffffff
wmt sf controller initial ok
Creating 6 MTD partitions on "mtdsf device":
0x000000000000-0x000000d00000 : "filesystem-SF"
0x000000d00000-0x000000f80000 : "kernel-SF"
0x000000f80000-0x000000fd0000 : "u-boot-SF"
0x000000fd0000-0x000000fe0000 : "u-boot env. cfg. 1-SF"
0x000000fe0000-0x000000ff0000 : "u-boot env. cfg. 2-SF"
0x000000ff0000-0x000001000000 : "w-load-SF"
1PMNAND_ADDR=0x8 
kmalloc buffer env_ptr = 0xcd0e0000, env_ptr_nand = 0xcd0e0000
MTD dev0   size: 0x00d00000   : "filesystem-SF"
MTD dev1   size: 0x00280000   : "kernel-SF"
MTD dev2   size: 0x00050000   : "u-boot-SF"
MTD dev3   size: 0x00010000   : "u-boot env. cfg. 1-SF"
MTD dev4   size: 0x00010000   : "u-boot env. cfg. 2-SF"
MTD dev5   size: 0x00010000   : "w-load-SF"
MTD Dev3 isn't valid
## Warning: "wmt.io.nand" not defined

No NAND device found!!!

wmt_nfc_init failed.
nand: probe of nand.0 failed with error -12
i2c /dev entries driver
I2C PORT0: Transfer Mode = 1; Speed Mode = 1
i2c: adding wmt_i2c_adapter0.
i2c: successfully added bus

I2C PORT1: Transfer Mode = 1; Speed Mode = 1; I2C1 PLL = 20M
i2c: adding wmt_i2c_adapter1.
i2c: successfully added bus
[wmt_i2c_api_i2c_init]
[wmt_i2c_api_init] wmt_i2c_api_init.
i2c: wmt algorithm module loaded.
## Warning: "wmt.display.direct_path" not defined
vpp_init(boot logo 1)
[VPP] GOVW TG 0,vpu en 0,vpu path 0
div_addr_offs=0x35c PLL_NO=1 
[VPP] GOVW TG 0,vpu en 0,vpu path 0
[VPP] GOVW TG 1,vpu en 0,vpu path 0
[VPP] GOVW TG 1,vpu en 0,vpu path 0
[VO] vout_init: <1>vo_init_wm8435
--> lcd_init
vt1632 hw mode
[VOUT] ext dev : DVI
[VOUT] int dev : NO
## Warning: "wmt.display.user_res" not defined
## Warning: "wmt.display.regop" not defined
[VOUT] param 2:0:16:0:0:0
[VOUT] boot parm vo LCD opt 0,16, 0x0@0
## Warning: "wmt.display.param2" not defined
## Warning: "wmt.pwm.invert" not defined
----------------------[VOUT] pwm 0:25:50:99 -------------------
[VOUT] blt 0,scalar 25,period 50,duty 99
[VOUT] tmr 40000:0:10:46:800:20:10:23:480:10
[VOUT] tmr pixclk 40000000,option 0x0,hsync 10,hbp 46,hpixel 800,hfp 20,vsync 10,vbp 23,vpixel 480,vfp 10
[VOUT] boot argument vo1 2,vo2 9
[VO] vo_boot_init: <7>vo_boot_init(0)
vo_init_wm8440 (BOOT 800x480,0)
gefb: framebuffer at 0f800000, mapped to d0000000, using 8192k, total 8192k
Console: switching to colour frame buffer device 100x30
fb0: wmtfb frame buffer device
loadtime = -4
[VO] vo_boot_config: <7>vo_boot_config
[VO] vo_boot_config: <7>Exit vo_boot_config
div_addr_offs=0x35c PLL_NO=1 
[VPP] GOVW TG 0,vpu en 0,vpu path 0
[VPP] GOVW TG 1,vpu en 0,vpu path 0
[VPP] GOVW TG 1,vpu en 0,vpu path 0
fb1: WMT VPU frame buffer device
Enter pwm_init
mknod /dev/wmtgpio c 253 0
WMT vibrater driver load successfully!
uart.0: ttyS0 at MMIO 0xd8200000 (irq = 32) is a wmt serial
uart.1: ttyS1 at MMIO 0xd82b0000 (irq = 33) is a wmt serial
WMT Serial driver initialized: ok
brd: module loaded
loop: module loaded
nbd: registered device at major 43
pmem: 1 init
PPP generic driver version 2.4.2
PPP Deflate Compression module registered
PPP BSD Compression module registered
NET: Registered protocol family 24
## Warning: "wmt.io.mac.off" not defined
VIA Rhine Family Fast Ethernet Adapter Driver Ver. 5.08
Copyright (c) 2002 VIA Technologies, Inc.
eth0: VIA Rhine III Fast Ethernet Adapter
eth0: MAC=00:40:63:26:57:75 IO=0xd8004000 Mem=0xd8004000  IRQ=10 
usbcore: registered new interface driver asix
Linux video capture interface: v2.00
WonderMedia CMOS camera register OK 
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
[wmt-vd] prob /dev/wmt-vd major 236, minor 0, prdt ffb1a000/8e40000, size 100 KB
[wmt-vd] WonderMedia HW decoder driver inited
[wmt-lock] init ok, major=242, minor=1
## Warning: "wmt.gpo.cmos" not defined
Can't get cmos config in u-boot!!!!
nmi:major(252),minor(0)
Dean:spi_probe
spi irq num = 0x18
B:0
A:8
spi_probe: /dev/WMT_SPI major number 153, minor number 0, device number 1
WMT EVB SPI Controlor Driver OK!
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci_hcd: block sizes: qh 60 qtd 96 itd 160 sitd 96
PCI: enabling device 0000:00:04.0 (0040 -> 0042)
ehci_hcd 0000:00:04.0: EHCI Host Controller
drivers/usb/core/inode.c: creating file 'devices'
drivers/usb/core/inode.c: creating file '001'
ehci_hcd 0000:00:04.0: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:04.0: reset hcs_params 0x102204 dbg=1 cc=2 pcc=2 ordered !ppc ports=4
ehci_hcd 0000:00:04.0: reset hcc_params 6872 thresh 7 uframes 256/512/1024
ehci_hcd 0000:00:04.0: reset command 080002 (park)=0 ithresh=8 period=1024 Reset HALT
ehci_hcd 0000:00:04.0: MWI active
ehci_hcd 0000:00:04.0: irq 43, io mem 0xd8007900
ehci_hcd 0000:00:04.0: reset command 080002 (park)=0 ithresh=8 period=1024 Reset HALT
ehci_hcd 0000:00:04.0: init command 010009 (park)=0 ithresh=1 period=256 RUN
ehci_hcd 0000:00:04.0: USB 0.0 started, EHCI 1.00
usb usb1: default language 0x0409
usb usb1: udev 1, busnum 1, minor = 0
usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: EHCI Host Controller
usb usb1: Manufacturer: Linux 2.6.32.9-default ehci_hcd
usb usb1: SerialNumber: 0000:00:04.0
usb usb1: uevent
usb usb1: usb_probe_device
usb usb1: configuration #1 chosen from 1 choice
usb usb1: adding 1-0:1.0 (config #1, interface 0)
usb 1-0:1.0: uevent
hub 1-0:1.0: usb_probe_interface
hub 1-0:1.0: usb_probe_interface - got id
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 4 ports detected
hub 1-0:1.0: standalone hub
hub 1-0:1.0: no power switching (usb 1.0)
hub 1-0:1.0: individual port over-current protection
hub 1-0:1.0: power on to power good time: 20ms
hub 1-0:1.0: local power source is good
hub 1-0:1.0: trying to enable port power on non-switchable hub
drivers/usb/core/inode.c: creating file '001'
uhci_hcd: USB Universal Host Controller Interface driver
PCI: enabling device 0000:00:05.0 (0000 -> 0001)
uhci_hcd 0000:00:05.0: UHCI Host Controller
drivers/usb/core/inode.c: creating file '002'
uhci_hcd 0000:00:05.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:05.0: detected 2 ports
uhci_hcd 0000:00:05.0: uhci_check_and_reset_hc: cmd = 0x0000
uhci_hcd 0000:00:05.0: Performing full reset
uhci_hcd 0000:00:05.0: irq 43, io base 0xd8007b00
usb usb2: default language 0x0409
usb usb2: udev 1, busnum 2, minor = 128
usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: UHCI Host Controller
usb usb2: Manufacturer: Linux 2.6.32.9-default uhci_hcd
usb usb2: SerialNumber: 0000:00:05.0
usb usb2: uevent
usb usb2: usb_probe_device
usb usb2: configuration #1 chosen from 1 choice
usb usb2: adding 2-0:1.0 (config #1, interface 0)
usb 2-0:1.0: uevent
hub 2-0:1.0: usb_probe_interface
hub 2-0:1.0: usb_probe_interface - got id
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
hub 2-0:1.0: standalone hub
hub 2-0:1.0: no power switching (usb 1.0)
hub 2-0:1.0: individual port over-current protection
hub 2-0:1.0: power on to power good time: 2ms
hub 2-0:1.0: local power source is good
hub 2-0:1.0: trying to enable port power on non-switchable hub
drivers/usb/core/inode.c: creating file '001'
PCI: enabling device 0000:00:06.0 (0000 -> 0001)
uhci_hcd 0000:00:06.0: UHCI Host Controller
drivers/usb/core/inode.c: creating file '003'
uhci_hcd 0000:00:06.0: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:06.0: detected 2 ports
uhci_hcd 0000:00:06.0: uhci_check_and_reset_hc: cmd = 0x0000
uhci_hcd 0000:00:06.0: Performing full reset
uhci_hcd 0000:00:06.0: irq 43, io base 0xd8008d00
usb usb3: default language 0x0409
usb usb3: udev 1, busnum 3, minor = 256
usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb3: Product: UHCI Host Controller
usb usb3: Manufacturer: Linux 2.6.32.9-default uhci_hcd
usb usb3: SerialNumber: 0000:00:06.0
usb usb3: uevent
hub 1-0:1.0: state 7 ports 4 chg 0000 evt 0000
usb usb3: usb_probe_device
usb usb3: configuration #1 chosen from 1 choice
usb usb3: adding 3-0:1.0 (config #1, interface 0)
usb 3-0:1.0: uevent
hub 3-0:1.0: usb_probe_interface
hub 3-0:1.0: usb_probe_interface - got id
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
hub 3-0:1.0: standalone hub
hub 3-0:1.0: no power switching (usb 1.0)
hub 3-0:1.0: individual port over-current protection
hub 3-0:1.0: power on to power good time: 2ms
hub 3-0:1.0: local power source is good
hub 3-0:1.0: trying to enable port power on non-switchable hub
drivers/usb/core/inode.c: creating file '001'
usbcore: registered new interface driver cdc_acm
cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver usbserial
debug:1 by rubbitxiao
drivers/usb/serial/usb-serial.c: Had to override the open usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the write usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the close usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the write_room usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the chars_in_buffer usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the read_bulk_callback usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the write_bulk_callback usb serial operation with the generic one.
USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial Driver core
drivers/usb/serial/usb-serial.c: Had to override the read_bulk_callback usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the write_bulk_callback usb serial operation with the generic one.
uhci_hcd 0000:00:05.0: port 1 portsc 008a,00
uhci_hcd 0000:00:05.0: port 2 portsc 008a,00
USB Serial support registered for GSM modem (1-port)
usbcore: registered new interface driver option
option: v0.7.2:USB Driver for GSM modems
usbcore: registered new interface driver VIAUSBModem
LinuxVIAUSBD1.0.4:VIA USB CDMA Modem
drivers/usb/serial/usb-serial.c: Had to override the disconnect usb serial operation with the generic one.
USB Serial support registered for pl2303
usbcore: registered new interface driver pl2303
pl2303: Prolific PL2303 USB to serial adaptor driver
drivers/usb/serial/usb-serial.c: Had to override the write usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the close usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the write_room usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the chars_in_buffer usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the read_bulk_callback usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the write_bulk_callback usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the disconnect usb serial operation with the generic one.
drivers/usb/serial/usb-serial.c: Had to override the release usb serial operation with the generic one.
USB Serial support registered for GobiSerial
usbcore: registered new interface driver GobiSerial
GobiSerial: 1.0.20
udc: VIA UDC driver, version: 3 December 2007 (dma)
udc: pullup_disable()
mount_thread
udc: wmt_udc_probe - request_irq(0x2B) pass!
uhci_hcd 0000:00:06.0: port 1 portsc 008a,00
uhci_hcd 0000:00:06.0: port 2 portsc 008a,00
mice: PS/2 mouse device common for all mice
## Warning: "wmt.io.ts" not defined
===== UTK Touch Disabled!=====
wmt_rtc on
using rtc device, wmt-rtc, for alarms
wmt-rtc wmt-rtc.0: rtc core: registered wmt-rtc as rtc0
WMT Real Time Clock driver v0.54 initialized: ok
device-mapper: ioctl: 4.15.0-ioctl (2009-04-01) initialised: dm-devel@redhat.com
device-mapper: multipath: version 1.1.0 loaded
device-mapper: multipath round-robin: version 1.0.0 loaded
device-mapper: multipath queue-length: version 0.1.0 loaded
device-mapper: multipath service-time: version 0.2.0 loaded
WMT ATSMB (AHB To SD/MMC Bus) controller registered!
## Warning: "rootdev" not defined
Do not initialize mmc1 when boot from NandFlash.
[MMC/SD driver] ATSMB1 probe Failed!
sdmmc1: probe of sdmmc1.0 failed with error -22
## Warning: "wmt.io.bri_max" not defined
------------------ lcd_backlight_probe ---------------
Registered led device: lcd-backlight
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
logger: created 256K log 'log_main'
logger: created 256K log 'log_events'
logger: created 64K log 'log_radio'
Advanced Linux Sound Architecture Driver Version 1.0.21.
No device for DAI VT1603
No device for DAI HWDEC
i2c_transfer returned -5
WM8900 0-001b: Device is not a WM8900 - ID 0
WMT_SOC: dai_name=i2s, codec_name=vt1603
No device for DAI wmt-i2s-dai
[VPP] set audio(fmt 16,rate 44100,ch 2)
VT1603 Audio Codec 0.10
wmt.audio.i2s = vt1603:f1:f2:f1:f1:100
playback volume percent[100%]
## Warning: "wmt.audio.channel.invert" not defined
## Warning: "wmt.audio.amp" not defined
## Warning: "wmt.audio.call.sound.output" not defined
asoc: VT1603 <-> wmt-i2s-dai mapping ok
ALSA device list:
  #0: WMT_SOC (VT1603)
TCP cubic registered
NET: Registered protocol family 17
lib80211: common routines for IEEE802.11 drivers
lib80211_crypt: registered algorithm 'NULL'
## Warning: "wmt.io.pwkey" not defined
input: kpadPower as /devices/virtual/input/input0
[wmt_pm_init] battery_used = 3
PMC: WonderMedia Power Management driver
PMC: Power button is configured as soft power
[wmt_pm_init] power_on = 100 resume = 0 power_up = 500
registered taskstats version 1
===== VT1609 Touch Screen Driver Enabled!=====
## Warning: "wmt.vt1609.param" not defined
wmt.vt1609.param not set, use default parameter.
[VT160X] bus=spi0, p.x = 800, p.y = 480, gpio=0, irq=6
mount_thread
hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0000
hub 3-0:1.0: state 7 ports 2 chg 0000 evt 0000
## Warning: "wmt.tsc.key" not defined
Read wmt.tsc.key Failed.
input: VT1609 TSC as /devices/virtual/input/input1
VT1609 Touch Screen Driver Installed!
>>>> vx_max=2028,vy_max=1998, vxy=17 ver=0.1 <<<<
VT1609 Dual Touch Support Enabled.
wmt-rtc wmt-rtc.0: setting system clock to 2010-02-04 04:17:23 UTC (1265257043)
VT160X Battery: I2C1, Sample Interval:10 sec
VT160X SAR-ADC Battery Driver Installed!
RAMDISK: gzip image found at block 0
mmc0: new high speed SDHC card at address aaaa
mmcblk0: mmc0:aaaa SU08G 7.40 GiB 
 mmcblk0: p1
usb usb2: suspend_rh (auto-stop)
usb usb3: suspend_rh (auto-stop)
## VT1603A/VT1609 BAT##: vt1603 battery read error, errno-5
## VT1603A/VT1609 BAT##: vt1603 battery read error, errno-5
## VT1603A/VT1609 BAT##: vt1603 battery write error, errno-5
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: checktime reached, running e2fsck is recommended
EXT3 FS on ram0, internal journal
EXT3-fs: mounted filesystem with writeback data mode.
VFS: Mounted root (ext3 filesystem) on device 1:0.
## VT1603A/VT1609 BAT##: vt1603 battery read error, errno-5
## VT1603A/VT1609 BAT##: vt1603 battery write error, errno-5
## VT1603A/VT1609 BAT##: vt1603 battery write error, errno-5
usb usb1: uevent
usb 1-0:1.0: uevent
usb usb2: uevent
usb 2-0:1.0: uevent
usb usb3: uevent
usb 3-0:1.0: uevent
NTFS-fs warning (device mmcblk0): parse_options(): Option utf8 is no longer supported, using option nls=utf8. Please use option nls=utf8 in the future and make sure utf8 is compiled either as a module or into the kernel.
yaffs: dev is 187695104 name is "mmcblk0"
yaffs: passed flags "utf8=true"
yaffs: Bad mount option "utf8=true"
yaffs: dev is 187695104 name is "mmcblk0"
yaffs: passed flags "utf8=true"
yaffs: Bad mount option "utf8=true"
 rx_thresh : 18 ([S&F]=0x38, 64DW=0x18)
eth0: failed to detect cable link
Вытащил из девайса данный лог может поможет.

stuz
Опытный
Опытный
Сообщения: 50
Зарегистрирован: 17.12.2011 11:40
Откуда: Новосиб

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2345 » stuz » 31.05.2012 9:04

[quote="Blaze2владельцам-54-опции
Что там с 54 опцией (все работает)?
Мерцание не исправлено, я в курсе, а в остальном?[/quote]

все работает (и 2 камеры тоже, если брать мой файл)
мерцания не стало, как поменял 35000 на 50000

spid123
Начинающий
Начинающий
Сообщения: 2
Зарегистрирован: 31.05.2012 14:17
Откуда: Moskow

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2346 » spid123 » 31.05.2012 14:21

Помогите, купил планшет 8650 с Gsm, но там не работает сим карта, он ее не видит, пробовал шил, но ничего не выходит.
Вот сей аппарат aliexpress.com/product-fm/526314905-7-inch-VIA-8650-phone-call-function-sim-card-Android-2-2-tablet-pc-with-GSM-wholesalers.html
Помогите дайте ссылку на рабочую прошивку.

Аватара пользователя
Blaze
Информатик-аналитик
Информатик-аналитик
Сообщения: 8926
Зарегистрирован: 24.05.2007 17:23
Модель телефона: POCO X3 Pro 6/128
Прошивка: crDroid v7.7
Sat-ресивер: Tiviar Mini HD
Откуда: Данков
Контактная информация:

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2347 » Blaze » 31.05.2012 18:14

Rossa писал(а): env_uboot изменил как писал stuz, но мерцание есть... :P
см. здесь, только в \FirmwareInstall\packages\android2.2-froyo.tgz в файле init.rc
найдите

Код: Выделить всё

write /proc/sys/vpp/pixel_clock 35000000
и замените на:

Код: Выделить всё

write /proc/sys/vpp/pixel_clock 50000000
Откройте файл init.rc через Notepad++ (скачайте и установите файл Notepad++ vx.x.x.x Installer)

spid123, резервные копии остались? 38 или 44 номер пробовали?

DeafenThunder, вам необходимо найти нужный uzImage.bin
Скопировал uzImage.bin из разных прошивок, что у меня на жестком лежали.
Возможно один из uzImage.bin подойдет - скачать можно здесь

poer
Начинающий
Начинающий
Сообщения: 5
Зарегистрирован: 30.05.2012 2:20
Откуда: Казахстан

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2348 » poer » 31.05.2012 21:34

Blaze доброго времени суток вам.Я писил чуть выше про прошивку ( M009F на базе процессора InfoTMIC x210 ) возникла следущая проблема возможно вы сталкивались с подобной.Перепрошил планшет он запустился всё работает всё отлично,как только планшет выключаю при повторном включении он зависает на ANDROID дальнейшая перезагрузка не приводит ровным счетом ни к чему кроме того же самого ANDROID стоит опять перепрошить и он сразу после прошивки включается и работает как в ни в чом не бывало,обратил внимание что память забита там нет места.Может ли забитая память так подгружать планшет и если да то как это исправить?Спасибо за внимание. :oops:
Последний раз редактировалось poer 31.05.2012 21:41, всего редактировалось 1 раз.

Аватара пользователя
Blaze
Информатик-аналитик
Информатик-аналитик
Сообщения: 8926
Зарегистрирован: 24.05.2007 17:23
Модель телефона: POCO X3 Pro 6/128
Прошивка: crDroid v7.7
Sat-ресивер: Tiviar Mini HD
Откуда: Данков
Контактная информация:

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2349 » Blaze » 31.05.2012 21:40

Добрый вечер poer.

То есть вы прошили планшет M009F одной из прошивок

Код: Выделить всё

EKEN_M009F_Android23_Gmac_PDS_V0.1.ius
EKEN_M009F_Android23_UsbNet_PDS_V0.1.ius
с помощью USB-флешки?

spid123
Начинающий
Начинающий
Сообщения: 2
Зарегистрирован: 31.05.2012 14:17
Откуда: Moskow

Re: Прошивка устройств на процессоре VIA WM8650

Непрочитанное сообщение#2350 » spid123 » 01.06.2012 0:02

Blaze, копии не осталось, планшет мне пришел и он изначально не работал (gsm), я думал дело в прошивке, но может дело не в ней? и 38 и 44 все пробовал но сим карту так и не видит.

Ответить